December 2017  |  01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

CentOS 5のアップデートがしばらくできなくて

JUGEMテーマ:コンピュータ
CentOS5のマシンのアップデートがやけに多いなあと思ったら、アップデートできてなかった。今日も yum update、こもっていると、ときどき気になって、日課のようになっている。

 Transaction Check Error:   file /usr/share/man/man1/curl.1.gz from install of curl-7.21.7-5.el5.remi.2.x86_64 conflicts with file from package curl-7.15.5-15.el5.i386

remiのパッケージのおかげでコンフリクトが起きてる。remiリポジトリから、phpの最新版を入れられて、便利なのだけど、ときどき手当が必要。

しばらく時間もなくて、そのままになってた。
書き物をしてると、煮詰まって気晴らしついでに、エラーメッセージで検索してみたりするのだけど、ぴったしの解決はなかったり、いっぱいパッケージを消してしまわなければならなかったりで、本腰入れて入れなおすのは、どうも気が進まないのばかり。

とまあ、なにげなく眺めてたのだが、

http://forums.fedoraforum.org/showthread.php?t=229277

で、ふと目に留まった短いおまじない。

rpm -ev --nodeps curl.i386

で、助かった気がした。このおまじないのあと、アップデートするとうまく置き換わったようだった。

Replaced:
  curl-devel.i386 0:7.15.5-15.el5       curl-devel.x86_64 0:7.15.5-15.el5    
 
まだ、もうひとつ解消できてない悩み事はあるのだが、こちらは、 --skip-broken で凌いでる。

Skipped (dependency problems):
  ImageMagick-last-libs.x86_64 0:6.7.8.10-1.el5.remi    




スポンサーサイト

pagetop