December 2019  |  01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31

されど pi-camera

JUGEMテーマ:コンピュータ

 

Raspbian OSを使うと、Raspberry Piに Pi Camera を繋ぐと簡単に画像や動画が撮影できる。

Pi Camera Rev 1.3 なるものが手元にあったのを思い出して、繋いでみたが、意外と手こずった。

 

ググると次のような手順がすぐにみつかる。

 

手順 0) Pi Camera をRaspberry Pi本体に接続してブート

手順 1) 未設定の場合は、raspi-config でカメラモジュールをサポートにしてリブート

手順 2) 撮影コマンドraspistillやraspividを実行

 

ハードの接続に問題がなければ、vcgencmd をつぎのように実行すると、

$ vcgencmd get_camera
output: supported=1 detected=1

のような結果となる。ここで、接続異常の場合は、

output: supported=1 detected=0

となるので、コネクター回りの接続状態を確認する必要がある。


正常に接続されていても、撮影コマンドを実行すると、また、エラーが出てしまった。

$ raspistill -o image.jpg
mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

待ちきれないので、Ctrl+Cを押下。

^Cmmal: Aborting program

 

エラーでググってみると、/boot/config.txt を編集し、core_freq=250 にしてとか、さらにだめなら、Pi CameraのLEDをオフにする disable_camera_led=1を設定して、リブートをすればよいなどあった。

 

うちの Pi はそれでもうまくゆかなかったので、 /boot/config.txtを眺めてみると arm_freq=900 にて、オーバードライブモードにしてあったので標準の700に戻してリブートするとうまくいったので、LEDは元に戻した。

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=900
arm_freq=700

# for more options see http://elinux.org/RPi_config.txt
core_freq=250
sdram_freq=400
over_voltage=0
start_x=1
gpu_mem=128

#uncomment for pi-camera led set to off
#disable_camera_led=1

 

結構、微妙なんだな、たまにエラーが。。。

Pi 3でうまくゆかなかったのは、このためか?

 

 

 

参照

https://raspberrypi.stackexchange.com/questions/74631/raspberry-pi-camera-module-not-working-v1-3

http://osoyoo.com/2017/05/17/%E3%83%A9%E3%82%BA%E3%83%91%E3%82%A4%E5%B0%82%E7%94%A8%E3%82%AB%E3%83%A1%E3%83%A9%E3%81%AE%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E6%96%B9%E6%B3%95/

 

 

 

スポンサーサイト

comments

   

trackback

pagetop